53 lines
1.6 KiB
Nix
53 lines
1.6 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{ config, lib, pkgs, modulesPath, ... }:
|
||
|
||
{
|
||
imports = [
|
||
(modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot = {
|
||
initrd = {
|
||
availableKernelModules = [
|
||
"xhci_pci"
|
||
"nvme"
|
||
"usb_storage"
|
||
"sd_mod"
|
||
"rtsx_pci_sdmmc"
|
||
];
|
||
kernelModules = [ ];
|
||
luks.devices."luks-c21cb4a4-f618-43af-bc0c-e8be74fe3b81".device = "/dev/disk/by-uuid/c21cb4a4-f618-43af-bc0c-e8be74fe3b81";
|
||
};
|
||
kernelModules = [ "kvm-intel" ];
|
||
extraModulePackages = [ ];
|
||
};
|
||
|
||
fileSystems = {
|
||
"/" = {
|
||
device = "/dev/disk/by-label/NIX-ROOT";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
"/boot/efi" = {
|
||
device = "/dev/disk/by-label/NIX-BOOT";
|
||
fsType = "vfat";
|
||
};
|
||
};
|
||
|
||
swapDevices = [
|
||
{ device = "/dev/disk/by-label/SWAP"; }
|
||
];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.eno1.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.wlp111s0.useDHCP = lib.mkDefault true;
|
||
|
||
powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|