flakes/webdev/flake.nix
2024-12-28 20:08:29 +01:00

30 lines
584 B
Nix

{
description = ''
Web development flake
'';
inputs = {
nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
flake-utils.url = "github:numtide/flake-utils";
};
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem
( system:
let
pkgs = import nixpkgs {
inherit system;
config.allowUnfree = true;
};
in {
devShells.default = pkgs.mkShell {
packages = with pkgs; [
nodejs
# IDE's
(jetbrains.plugins.addPlugins jetbrains.webstorm [ "github-copilot" ])
];
};
});
}