down-message/flake.nix
2023-08-05 19:32:53 +02:00

28 lines
551 B
Nix

{
description = "down-message";
inputs.flake-utils.url = "github:numtide/flake-utils";
outputs = { self, nixpkgs, flake-utils }:
flake-utils.lib.eachDefaultSystem
(system:
let
pkgs = import nixpkgs {
inherit system;
config.allowUnfree = true;
};
in {
devShells.default = pkgs.mkShell {
packages = with pkgs; [
jetbrains.webstorm
nodejs
nodePackages.live-server
];
shellHook = ''
webstorm . && exit
'';
};
}
);
}